ubuntu - thunderbird - gmx - problem :(

Alles über alternative Betriebssysteme und ihre Anwendungen
Antworten
Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

ubuntu - thunderbird - gmx - problem :(

Ungelesener Beitrag von Merowinger » 23.06.2007, 18:09

Ich weiß net so recht wohin damit, aber ich tus mal hier rein...

also Problem ist, dass ich unter einem frisch installiertem ubuntu 7.04 mit thunderbrid keine gmx-mails empfangen kann (keine Fehlermeldung aber eben auch kein Empfang) und auch nicht senden (beim senden nimmt er das passwort nicht an).

- einstellungen und Passwort sind absolut 1:1 von einem Win-PC übernommen worden, da läuft Thunderbird in exakt der selben version(1.5.0.12) mit exakt der selben Konfig und alles geht astrein

- Internet allgemein funzt auf dem Ubuntu-System natürlich auch

- Auf einem anderen PC habe ich selbst das gleiche(ubuntu/tunderbird) für mich installiert, allerdings mit web.de als Provider, da läuft es auch. wtf...kann doch nicht sein, dass gmx nur unter linux nicht geht....

Benutzeravatar
usr
Rear Admiral
Turtleboard Veteran
Turtleboard Veteran
Beiträge: 2338
Registriert: 08.03.2004, 17:32
Kontaktdaten:

Ungelesener Beitrag von usr » 23.06.2007, 19:55

Wie ist die MTU von deiner Linux Kiste?

Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

Ungelesener Beitrag von Merowinger » 24.06.2007, 11:56

laut ifconfig habich ne MTU von 1500, hab schon probiert mit

Code: Alles auswählen

sudo ifconfig eth0 mtu 1492
was anderes einzustellen, aber ohne sichtbaren Erfolg :(. Unter windows habe ich per ping ne MTU von 1464(1492) gemessen.

Was tun?

Benutzeravatar
keyan
Lt. Commander
Beiträge: 161
Registriert: 09.03.2004, 19:36
Wohnort: Berlin
Kontaktdaten:

Ungelesener Beitrag von keyan » 24.06.2007, 13:54

Einfach in die /etc/network/interfaces

Code: Alles auswählen

auto eth0
iface eth0 inet dhcp
post-up ifconfig eth0 mtu 1492
oder eben entsprechende static Konfiguration übernehmen.

Dann sollte es ja schon nach einem

Code: Alles auswählen

sudo ifdown eth0
und

Code: Alles auswählen

sudo ifup eth0
funktionieren.

Edit: Komischerweise muß ich bei meinem Feisty Fawn die MTU immer auf 1500 zwingen, da sie automatisch 1492 ist.

Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

Ungelesener Beitrag von Merowinger » 25.06.2007, 11:52

wie finde ich denn unter linux die optimale mtu-einstellung heraus für die kombination ubuntu/router/gmx? Hab jetzt mal 2,3 ausprobiert aber nur nen Teilerfolg(der smtp geht, der pop ruft aber keine mails ab). Und ich will ungern manuell 100 Werte durchprobieren ;)

Benutzeravatar
keyan
Lt. Commander
Beiträge: 161
Registriert: 09.03.2004, 19:36
Wohnort: Berlin
Kontaktdaten:

Ungelesener Beitrag von keyan » 25.06.2007, 13:19

Code: Alles auswählen

tracepath
sollte da helfen!

Benutzeravatar
keyan
Lt. Commander
Beiträge: 161
Registriert: 09.03.2004, 19:36
Wohnort: Berlin
Kontaktdaten:

Ungelesener Beitrag von keyan » 27.06.2007, 13:40

Hats nun geklappt?

Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

Ungelesener Beitrag von Merowinger » 27.06.2007, 15:26

hmh da werd ich nicht schlau draus. keine der beiden traceroute-versionen zeigt mir mtus an bzw errechnet diese. Auch mit dem "no Fragment Bit" sehe ich keinen Unterschied...

Code: Alles auswählen

traceroute -F pop.gmx.net

traceroute to pop.gmx.net (213.165.64.22), 30 hops max, 40 byte packets
 1  fritz.slwlan.box (192.168.178.1)  0.367 ms  0.298 ms  0.241 ms
 2  * * *
 3  212.6.112.194 (212.6.112.194)  10.669 ms  10.083 ms  9.343 ms
 4  ge-6-0-5-0-hb-0.hb.ewe-ip-backbone.de (212.6.114.110)  10.382 ms  10.352 ms  10.779 ms
 5  bbrt.ffm-0-10ge-6-0-0.ewe-ip-backbone.de (212.6.114.14)  19.790 ms  20.001 ms  20.429 ms
 6  de-cix2.1und1.net (80.81.193.123)  27.014 ms  23.774 ms  24.791 ms
 7  te-1-4.bb-c.bs.kae.de.oneandone.net (212.227.120.9)  23.349 ms  23.811 ms  23.803 ms
 8  ae-3.gw-distg-a.bs.ka.oneandone.net (212.227.121.214)  24.145 ms  23.707 ms  23.600 ms
 9  pop.gmx.net (213.165.64.22)  23.354 ms  24.040 ms  22.570 ms
Alles was ich sehe ist, dass er direkt hinter meinem Router sehr lange braucht, bis was kommt. aber wie ich das nun ändere, keinen Plan :(

Edit: Wenn ich eine Paketgröße über meiner MTU angebe als Parameter, bekomme ich natürlich ne Fehlermeldung "Package too long" hilft aber auch nicht recht weiter.

Benutzeravatar
keyan
Lt. Commander
Beiträge: 161
Registriert: 09.03.2004, 19:36
Wohnort: Berlin
Kontaktdaten:

Ungelesener Beitrag von keyan » 27.06.2007, 15:43

Ich meinte ja auch tracepath und nicht traceroute, tracepath zeigt Dir nämlich die MTU auf dem Weg zum Ziel an.

Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

Ungelesener Beitrag von Merowinger » 27.06.2007, 18:20

keyan hat geschrieben:Ich meinte ja auch tracepath und nicht traceroute, tracepath zeigt Dir nämlich die MTU auf dem Weg zum Ziel an.
whoops, falsch gelesen. Aber so wirklich bringt mich das nciht weiter...

Code: Alles auswählen

tracepath pop.gmx.net
 1:  noname (192.168.178.31)                                0.202ms pmtu 1436
 1:  fritz.slwlan.box (192.168.178.1)                       0.613ms 
 2:  no reply
 3:  212.6.112.194 (212.6.112.194)                        asymm  4  31.983ms 
 4:  ge-6-0-5-0-hb-0.hb.ewe-ip-backbone.de (212.6.114.110) asymm  5  32.925ms 
 5:  bbrt.ffm-0-10ge-6-0-0.ewe-ip-backbone.de (212.6.114.14) asymm  6  42.496ms 
 6:  de-cix2.1und1.net (80.81.193.123)                     46.230ms 
 7:  te-1-3.bb-c.bs.kae.de.oneandone.net (212.227.120.29)  45.169ms 
 8:  ae-3.gw-distg-a.bs.ka.oneandone.net (212.227.121.214)  45.576ms 
 9:  pop.gmx.net (213.165.64.22)                           46.681ms reached
     Resume: pmtu 1436 hops 9 back 9 
So, da zeigt er mir die MTU an, die ich eingestellt habe (1436). Und es bestätigt sich, dass die erste IP-Adresse hinter dem Router wohl nicht erreicht wird... :( Was nun?

Benutzeravatar
keyan
Lt. Commander
Beiträge: 161
Registriert: 09.03.2004, 19:36
Wohnort: Berlin
Kontaktdaten:

Ungelesener Beitrag von keyan » 27.06.2007, 22:09

Also die MTU ist ja dann wirklich sehr vorsichtig gewählt :) Zumindest siehst Du, daß sie auch eingestellt ist. Da kommt nun eigentlich wieder usr ins Spiel, der hat die Idee mit der MTU gebracht :)

Ich sags mal so, ubuntu mag auf alle Fälle mein GMX Konto, auch mit der MTU von 1500. Ich könnte mir höchstens vorstellen, dass irgendein kleiner Fehler sich in die Konfiguration vom TB eingeschlichen hat, evtl. sichere Authentifizierung aktiviert, SSL etc.

Benutzeravatar
usr
Rear Admiral
Turtleboard Veteran
Turtleboard Veteran
Beiträge: 2338
Registriert: 08.03.2004, 17:32
Kontaktdaten:

Ungelesener Beitrag von usr » 27.06.2007, 22:10

Ich tippe auch mal auf Mailclient-Fehlkonfiguration, das lässt so schön viel Spielraum ;)

Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

Ungelesener Beitrag von Merowinger » 27.06.2007, 22:13

die config habe ich mit screenshots vom windows-tb verglichen, da stimmt alles. Zudem läuft ja auch alles, sogar beim abrufen keine fehlermeldung...nur eben auch keine Mails.

Nicht zu vergessen, dass nach Änderung der MTU auf einmal der smtp lief...

Benutzeravatar
Aero
Rear Admiral
Turtleboard Veteran
Turtleboard Veteran
Beiträge: 2755
Registriert: 08.03.2004, 16:17
Wohnort: Münster

Ungelesener Beitrag von Aero » 28.06.2007, 08:03

Die MTU für Ethernet ist 1500 (du bist ja hinter dem Router) und für DSL <=1492. Halte dich an Standards und gut ist :P Und wenn das Internet geht, wirds kaum an der MTU-Konfig liegen. :P

Antworten