Ubuntu 7.10 - Speedstep Problem

Alles über alternative Betriebssysteme und ihre Anwendungen
Antworten
Benutzeravatar
st3660a
Vice Admiral
Turtleboard Veteran
Turtleboard Veteran
Beiträge: 4761
Registriert: 08.03.2004, 14:00
Kontaktdaten:

Ubuntu 7.10 - Speedstep Problem

Ungelesener Beitrag von st3660a » 14.11.2007, 18:19

Hi,
hab auf mein Acer Notebook (siehe Profil) Ubuntu 7.10 installiert.
Soweit funktioniert auch alles, allerdings stört mich extrem, dass selbst surfen mit dem Firefox schon ausreicht um die CPU immer wieder auf Maximaltakt zu bringen. Resultat ist ein ständig kurz anlaufender Lüfter.
Unter WindowsXP mit dynamischer Taktanpasung geht der Lüfter außer beim zocken nie an und die CPU langweilt sich meist bei 600MHz Minimaltakt.
Ähnlich war es bei Ubuntu 7.06 (?). Da konnte ich auch wesentlich mehr Einstellungen bei dem "Überwachen der Prozessortaktstufen" Tool machen.

Also meine Fragen:
1. Warum braucht die 7.10er Version für Firefox mit drei offenen Seiten (2x Hartware Forum, 1xWiki von ubuntuusers.de) und einer Console über die ich per SSH auf nem Uni Rechner rumfummel so viel CPU Power? Läuft da was falsch bei mir?
2. Warum kann ich in dem "Überwachen der Prozessortaktstufen" Tool nix mehr einstellen? Lösung?

Danke euch!

Benutzeravatar
Lynx
Captain
Beiträge: 699
Registriert: 18.03.2004, 07:48

Ungelesener Beitrag von Lynx » 14.11.2007, 22:16

Ja hab ich mich auch gewundert, Grund ist daß es einen neuen "conservative" governor gibt der im Gegensatz zu on-demand nicht immer gleich auf volle Power schaltet, sondern halbwegs gedämpft arbeitet.
Aber in der Tat kann man nichts im CPU Frequency Scaling Monitor einstellen, dazu muß man erst
sudo chmod +s /usr/bin/cpufreq-selector
ausführen, dann ist plötzlich alles da.

Der user-space governor + powernowd jetzt nicht mehr default, und eigentlich überflüssig, außer man will tausende angepasster Profile erstellen wie es bei cpufreqd möglich ist, das war mir aber schon immer vieeel zu umstädnlich.

Etwas mehr Info:
http://wiki.ubuntuusers.de/Prozessortaktung
steht auch wie man was anderes als on-demand als default einstellt...

Benutzeravatar
st3660a
Vice Admiral
Turtleboard Veteran
Turtleboard Veteran
Beiträge: 4761
Registriert: 08.03.2004, 14:00
Kontaktdaten:

Ungelesener Beitrag von st3660a » 15.11.2007, 08:34

Les nochmal genau was ich geschrieben habe, der taktet mir zu SCHNELL hoch, nicht zu langsam. Oder hab ich dich falsch verstanden? "conservative" würde ich als ehere niedrigere Taktfrequenzen interpretieren oder lieg ich da falsch?

*edit*
War wohl mein Fehler :)
Hab den Modus jetzt auf conservative stehen. Schon besser und ich kann auch Minimaltakt erzwingen. Sehr schön :)

Eine Frage hab ich noch: Es kommt gelegentlich vor, dass der Rechner im idle Zustand (sprich ich arbeite per SSH auf nem anderen Rechner und mach lokal eigentlich nichts, oder ich sitz grad vor meinem "großen" PC) wie wild auf der Platte rumrödelt. Wie kann ich feststellen was das ist? Ich hab ja die neue Suchfunktion in Verdacht (bzw. deren Indexdienst), war bei Vista anfangs auch so. Allerdings ist mein Userverhalten hier am Notebook etwas anders, weshalb ich die Suche hier eigentlich nicht brauche. Wie kann ich die deaktivieren?

Benutzeravatar
fassy
Vice Admiral
Turtleboard Veteran
Turtleboard Veteran
Beiträge: 5855
Registriert: 26.01.2004, 20:44
Wohnort: Hamburg

Ungelesener Beitrag von fassy » 15.11.2007, 10:35

Mal mit top und ps beobachten.
Pick up the hammer... pick it up.

Benutzeravatar
picasso
Rear Admiral
Beiträge: 3220
Registriert: 08.03.2004, 12:15
Wohnort: Schweiz =)
Kontaktdaten:

Ungelesener Beitrag von picasso » 15.11.2007, 10:59

Jo, 7.10 benützt zum suchen und indexieren Tracker, das macht bei mir auch oft viel CPU-Load obwohl mein Homeverzeichnis praktisch leer ist. Ich habe Tracker inzwischen deaktiviert und benütze Beagle, damit bin ich für den Moment glücklicher (Beagle hat auch eine Option, um das indexieren im Batteriemodus zu stoppen).
:wq!

Antworten