Hilfe! SSD geschrottet durch Passwortvergabe?

RAM, Festplatten, DVD, CD, Sticks, Zip, Streamer und andere Massenspeicher
Antworten
Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

Hilfe! SSD geschrottet durch Passwortvergabe?

Ungelesener Beitrag von Merowinger » 22.07.2011, 21:55

Der Titel sagt ja schon einiges, ich fürchte, ich habe gerade meine Intel X25-M geschrottet.

Ich wollte das SECURE ERASE Kommando drauf ausführen mittes HDDERASE, das hat aber nie richtig geklappt, weil Platte nicht erkannt oder gelockt, je nach System. Okay, also unter Linux versucht. Erst mit diesem Kommando:

Code: Alles auswählen

hdparm --user-master u --security-erase NULL /dev/sda
Das schlug fehl, weil er wohl ohne gesetztes Passwort nicht arbeiten konnte. Okay, also Passwort gesetzt:

Code: Alles auswählen

hdparm --user-master u --security-set-pass test /dev/sda
und danach nochmal Secure Erase:

Code: Alles auswählen

hdparm --user-master u --security-erase test /dev/sda
Schien alles bestens geklappt zu haben. So, nun wusste ich natürlich, dass das Passwort wieder raus muss, also folgendes gemacht:

Code: Alles auswählen

hdparm --user-master u --security-set-pass NULL /dev/sda
Ich vermute mal, ich hätte die Security Option an der Stelle sofort komplett abstellen müssen, etwa mit --security-unlock, hab ich aber nicht getan :(. Rebootet, und dann ging der Spaß los. Der PC kann gar nicht mehr auf die SSD zugreifen, nichtmal das BIOS. Auch unter Ubuntu keine Chance, weil die SSD beim Start gar nicht erst gemountet wird.

Mein HP Notebook kennt scheinbar diese Security Optionen, der hat beim Hochfahren mit der SSD dann eine "Drive Bay locked" Meldung ausgegeben. Ich hab ein paar mal mein Passwort eingegeben und Enter gedrückt, mit dem Erfolg dass ein paar Mal nix passierte, und nun steht da nur noch "number of retries exeeded, drive is locked". Trotz richtigem Passwort.

Sieht irgendwer irgendeine Option, die SSD noch zu retten? Gibt es irgendwelche Tools/Linux-Kommandos, mit denen man quasi den Controller wieder in den Ursprungszustand versetzen kann? Einsenden zu Intel wäre sonst auch noch ne Option, wobei ich fast denke, das wird teurer als der Zeitwert der Platte :(

Hülfää :(

Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

Re: Hilfe! SSD geschrottet durch Passwortvergabe?

Ungelesener Beitrag von Merowinger » 22.07.2011, 22:59

Woo-hoo, ich glaube ich bin ein Stück weiter. Nach einmal komplett Strom ausschalten hatte ich wieder eine Passworteingabe-Möglichkeit. Und dort dann mal nur Enter gedrückt und siehe da: "OK!". Muss ich nicht verstehen.

Danach dann die Live-CD gebootet und erstmal nur Input/Output Error gehabt, bei allem was ich machen wollte. Durch Zwischenzeitliches Ausstöpseln der SSD im Betrieb habe ich es dann irgendwie geschafft, die SSD nochmal zu secure erasen und das Passwort zu deaktivieren (hoffentlich). Dann Mit Gparted ne neue Partitionstabelle angelegt, neu gestartet und nu kommt gerade Win 7 drauf. Ganz ausschalten hab ich mich noch nicht getraut. Es bleibt spannend.

Man man...wenn man nix zu tun hat und mal wieder Nervenkitzel will, einfach mal irgendwelche schwindeligen Linux-Kommandos auf teure Hardware loslassen... *Schweiss abwisch*

sompe
Vice Admiral
Turtleboard Veteran
Turtleboard Veteran
Beiträge: 7682
Registriert: 08.03.2004, 15:03

Re: Hilfe! SSD geschrottet durch Passwortvergabe?

Ungelesener Beitrag von sompe » 23.07.2011, 01:52

Ich vermute mal das du mit "-set-pass NULL" zwar das Passwort an sich geloescht aber den Passwortschutz an sich nicht entfernt hattest.
Damit bliebe die Passwortabfrage erhalten aber sobald man eines eingibt ist es natuerlich falsch, weil er ganz einfach erwartet das nichts eingegeben wird.

Das sagt mir aber nur die Logik, da ich nahezu 0 Plan von Linux hab. :D

Benutzeravatar
Merowinger
Fleet Captain
Beiträge: 1865
Registriert: 19.12.2004, 14:44

Re: Hilfe! SSD geschrottet durch Passwortvergabe?

Ungelesener Beitrag von Merowinger » 23.07.2011, 09:16

So sehe ich das auch mit dem Passwort. Aber das dann wieder nachträglich zu korrigieren, war mehr Glück als Verstand. Hätte ich nicht zufällig ein Notebook gehabt, was die Passworteingabe unterstützt vom BIOS aus, wär wohl Schicht gewesen.

Wie auch immer, nach diversen Reboots läuft immer noch alles. Thema erledigt und SSD wieder sauschnell :)

Antworten